Posted by: reformedmusings | October 26, 2014

Disastrous upgrade to Ubuntu 14.10 Utopic Unicorn

So, I was doing non-computer stuff the other day and noticed that Ubuntu released 14.10 Utopic Unicorn. I’ve been on 14.04 LTS, so the upgrade should have been trivial as so many have been over the years. As usual, I used the GUI updater to perform a routine upgrade. I let it run whilst doing other things until I noticed two lights flashing simultaneously on my keyboard. Checking the screen, I saw that the upgrade had frozen part-way through the installation. Rats. Now I surely had a unstable, unbootable system stuck in never-never land. Not what I had in mind.

First, I tried rebooting into a recovery mode which worked. I then used several commands to attempt to finish the upgrade:

apt-get update
apt-get dist-upgrade
dpkg –configure -a

This made sure that all packages were available, then upgraded the distribution, then lastly tried to repair any packages that didn’t install properly. The combination netted me a bootable Utopic system, but one using the Noveau open source video driver. I wanted to use my native NVidia driver, so went into Settings -> Software & Updates -> Additional Drivers, then selected the newest tested NVidia driver. I could not tell if that change completed, but I then restarted to load the new driver.

Net result was a working login screen, but after logging in, all I got was the background wallpaper. No Unity launcher or bar at the top of the screen. I was able to get into Settings by right-clicking on the desktop and selecting Change Desktop Background, but could not change the video driver again.

I dropped to the console using Ctrl-Alt-F2 in several attempts to recover the system, but all attempts to recover the video system failed. I’ll spare you the hours of details, but the bottom line is that there’s a bug in the NVidia installation script which causes problems with Unity and Compiz, and it’s not easy to recover from. In frustration, I booted into a Mint 12 setup that I had on another hard drive in my system, downloaded the Utopic DVD image, burned it to a DVD, then tried installing that.

The good news: Ubuntu recognized that I already had a 14.10 installation and offered to fix it while preserving all my apps. That seemed like a no-brainer, so I went for it.The bad news: it didn’t use my old /Home directory, but rather created its own. My regular /Home directory is a RAID 1 Array, which complicates the matter a bit. The old Alternate CD used to accommodate RAID arrays nicely, but that disk doesn’t appear to exist anymore. The Desktop DVD doesn’t have a clue about RAID arrays.

So, I went back to scratch, realizing that I’d have to reinstall all my apps but at least the settings and data would be preserved. So, I rebooted back to the Desktop DVD, manually configured the /Home directory, then learned that the mdadm RAID manager isn’t loaded by default, so I could not make my RAID 1 array the /Home directory. After several clever attempts to fool the system, I ended up making one of the RAID disks /Home by manually setting it in /etc/fstab, finishing the installation, then installing mdadm and reintegrating the array, manually setting the array as /Home in the /etc/fstab file. That worked like a charm, but was time consuming.

Since the Unity launcher didn’t work, I installed the Gnome desktop from Ctrl-Alt-F2 console and used it. I will comment on that desktop when I get a chance, but I found using that desktop extremely frustrating. But, it worked and I was able to use it to fix the Unity setup. That involved wiping the Unity (unity-tweak-tool –reset-unity) and Compiz (deleted the .compiz directories on /Home) settings clean and starting from scratch. Those actions proved the last keys to success.

I also ran into a bizarre problem with one of my USB hubs. It provided endless error messages that infused the entire recovery process and greatly slowed things down. Only by trial-and-error did I find the correct peripheral to disconnect. That hub worked perfectly before, so I plan to give it a try once I finish resetting up my system.

After finally obtaining a clean, working Utopic system, I had to reinstall all of my apps. Since I hadn’t done this for a while, I had to do some catch up on the Internet. I found help for psensors here, Adobe Reader here, Mouse help for Compiz settings here, creating an icon for grpn here, and got that icon here.

I am still installing cat and dog apps as I need them. Now that all is basically resolved, the Unity system seems stable. My experience with Gnome reinforced my appreciation for Unity. Although I wasn’t a Unity fan in the beginning, that system has progressed significantly to become almost intuitive.

As for the Ubuntu 14.10 upgrade, this proved to be the worst of any I’ve ever done over the last 7 years. Perhaps the fact that unicorns are mythical has something to do with it. I hope to see better in the future. Then again, it’s hard to complain about free.

 


Responses

  1. Ouch. My external hard drive just died, so I was hoping to install Utopic to half of my regular hard drive. Thank you for the warning. I still want to try, but you’ve given a very good list of what to watch out for.

    • I wish that I could tell you what originally caused the lockup, but I didn’t analyze that at the time. Beware the NVidia scripts for 133.

      • Thank you for warning about the Nvidia script. I have printed out your instructions for when I install Utopic.

        • The catch is to get the network access running under recovery mode so that you can install the gnome desktop if necessary. Shouldn’t be a problem if you don’t use RAID arrays.

  2. […] that my upgrade from 14.04 to 14.10 went very poorly and I ended up installing clean. Apparently, a Java runtime isn’t installed by Utopic 14.10 […]


Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Categories

%d bloggers like this: